Configure Mikrotik as a Hotspot Server


 Configure Mikrotik as a Hotspot Server :
 ———————————————————

network mikrotik hotspot
 Setup IP Address Ethernet
In my case, the Mikrotik to connect to the internet, simply by setting IP address dhcp. Open winbox, Click IP – DHCP Client. In the open dialog box & Click + Option

IP - DHCP Client

Select ether1 interface, and check peer dns, ntp peer and the default route. Then click Ok

New DHCP Client

Click new Terminal.  Make sure Mikrotik connect to internet

New Terminal

Setting DNS
Click IP – DNS. In the open dialog box, click Settings. New open dialog will be appear. Input IP DNS in the box Servers, for example 8.8.8.8.  and check Allow Remote Requests. Then click OK

DNS settings

Setting NTP (Network Time Protocol)
Click System – NTP Client. Continue to check enable and select Unicast mode, and then input IP address for Primary NTP Server & Secondary NTP Server, as shown below. Then click OK

NTP Client

Setting Mikrotik Hotspot
Continue to setting Hotspot. Click IP – Hotspot

IP - Hotspot

Hotspot dialog box, Click Hotspot Setup

Hotspot setup

Mikrotik Hotspot Setup wizard, will be appear. This is easiest way to setup Hotspot interface in Mikrotik. IP address for Ethernet, DHCP Server, routing and firewall will be configured automatically. In the Mikrotik Hotspot Setup wizard, select ether2 as hotspot interface.  Then click Next

select interface hotspot

Set hotspot IP address.  Then click Next

set hotspot address

Set Pool dhcp, then click Next

set pool dhcp for hotspot

SSL certificate, select none. Then click Next

select hotspot SSL

Enter 0.0.0.0 Click Next

select smtp server

Setup DNS, input IP DNS, then click Next

setup DNS hotspot

DNS name, leave blank, then click Next

DNS name for hotspot

Create users, and password,  then click Next

create hotspot user

Done. Setup has completed successfully

setup successfully

Mikrotik hotspot is working properly. Input username and password, that have been created

login page mikrotik

DHCP Server On Mikrotik Router


DHCP Server On Mikrotik Router
DHCP server is a protocol that enables any computer equipment in the local network to get an IP Address automatically. If the dhcp server protocol is not enable, then all computer equipment in the local network must be given an IP Address manually

Setting DHCP Server on Mikrotik Router
Login to mikrotik router using winbox
Go to IP

Click on IP & DHCP Servert3162434

Click DHCP setup box & Select interface to run DHCP server & Click next
3605b5a.jpg

Select network for DHCP Address Space 192.168.1.0/24 & Click next39c0220

Select Network Gateway for DHCP Network 192.168.1.1 & click Next01314ce

IP Addresses Given out by DHCP server addresses 192.168.0.2-192.168.0.25404fe332

Select DNS servers 8:8:8:8 & Click Next08de9c3.jpg

Select Lease Time 3d finally & Click Okt0c60700

DHCP is Completed16db138.jpg

Bandwidth Test Using MikroTik


Bandwidth Test Using MikroTik
Mikrotik Router also has a tool that can be used to determine how much traffic can be passed on a link or connection point. Proxy will generate traffic that will then be sent to another device via a connection line. This process is commonly called the Bandwidth test. A process consists of a test Bandwidth Bandwidth Bandwidth test servers and test client.
All versions can be used as a RouterOS Mikrotik Bandwidth Test or Bandwidth test server client.

bandwidthtest

BTEST Server (/ tool BTEST server)
Proxy already contained Bandwidth Test Server and can be used. So enough with the default configuration can be done on the Router Mikrotik bandwidth test. gambar_1

Enabled parameter (default: yes)
used to enable bandwidth test server on the router. If the position enabled = no (disable) or not checked (uncheck) it can not be done to test the bandwidth of the router.

Authenticate (default: yes)
As the regulator granting Bandwidth test for client authentication. Authenticate: yes (check), to be able to do the bandwidth test, Bandwidth Test Client must enter a username and password as the one used to perform remote server config Router BTEST.
Authenticate: no (unchecked), Bandwidth Test Client does not need to enter your username and password to perform the bandwidth test.

Parameter Max session
Used to set limitations on how Max session / bandwidth connection test which took place simultaneously.

Bandwidth Test Tool (/ tool Bandwidth Test)
Bandwidth test server, Mikrotik Bandwidth can also be used as a test client. Mikrotik Bandwidth test as Client can be configured on the menu / tool bandwidth test. gambar_2-1

Test Parameters
Used to designate the IP address of Router bandwidth test server.

Protocol
We can change the protocol to be used in a bandwidth test on the parameters of the protocol (TCP / UDP)

Direction
Used to specify the direction of traffic. There are 3 choices of direction of traffic to be generated

Upload (send)
Download (receive)
Uploading and downloading (both)

Local & Remote tx Speed
Used to determine the current transfer speed bandwidth test. Units bps (bits per second).

Username & Password
Adjust the router settings Btestserver. If the router BTEST server authentication parameters: yes then enter the username and password you use for the remote router.

IP Router Server = 192.168.5.215, tests using UDP protocol with the direction of traffic upload (send) & We trying to skip traffic with data transfer rate of 10Mbps. Fill in the Username & Password as the BTEST Server.

Btest-Cient2

Bandwidth test client could also use a PC with the help of Mikrotik Btest.exe applications. This application can be used to make Windows-based PCs as client and server bandwidth test

gambar_5

BTEST Server on the menu / tool BTEST server session. It would appear that the information bandwidth test is in progress.

Session

MikroTik Hotspot User Manager Configuration


MikroTik Hotspot User Manager Configuration
User Manager on Mikrotik Router is a management system that can be used for manage and control system on hotspot user, PPP (PPtP/PPPoE) users, DHCP users, Wireless users, and RouterOS users.

Usermanager

Install User Manager On MikroTik Router
Login to mikrotik router using winbox
Go to Files Menu
Drag & Drop usermanager.npk to Files Menu5-25-2015 11-09-49 PM

Reboot your mikroTik router, User Manager Package will be Installed Automatically

Open Your browser & Type
http://<WAN IP address Mikrotik Router>/userman
Enter Username to login = admin, password = blank5-25-2015 11-27-10 PM

Go to Customers Menu
Click Admin
Please Change the Login Password for Security5-27-2015 1-10-13 PM

VLAN Switch setup in Mikrotik Router Board


VLAN Switch setup in Mikrotik Router Board
VLAN Switch setup in Mikrotik Router Board Setup Below are the Steps & Details.

14034-mlb3844923936_022013-o

Ethernet2 is Master Port for trunking and Ethernet Port 3,4,5 is a Switch Port Manageable work Independently. Before setup you need to reset router and remove all default configuration.

Now Connect PC Lan wired on Ethernet1 (Port 1), Open Winbox & Paste Script on terminal.

Setting Interface as Master
/interface ethernet
set [ find default-name=ether3 ] master-port=ether2
set [ find default-name=ether4 ] master-port=ether2
set [ find default-name=ether5 ] master-port=ether2

Setting Switch Port
VLAN ID & Required setup VLAN ID
/interface ethernet switch port
set 1 vlan-header=add-if-missing vlan-mode=secure
set 2 default-vlan-id=100 vlan-header=always-strip vlan-mode=secure
set 3 default-vlan-id=200 vlan-header=always-strip vlan-mode=secure
set 4 default-vlan-id=300 vlan-header=always-strip vlan-mode=secure

Setting VLAN Switching
/interface ethernet switch vlan
add ports=ether3,ether2 switch=switch1 vlan-id=100
add ports=ether4,ether2 switch=switch1 vlan-id=200
add ports=ether5,ether2 switch=switch1 vlan-id=300

vlan

intervlan-routing

How To Setup PPPOE Server In MikroTIk


How To Setup PPPOE Server In MikroTIk
Wireless ISP/CABLE NET, PPPoE is the preferred method of getting your clients to dialup to your service. Making use of PPPoE allows you to get rid of static client IP addresses, make use of usernames and passwords, and enforce basic bandwith management

Create an “IP Pool” which is a range of IP addresses for the MikroTik router to hand out to clients when they sign in with their user names and passwords.  The IP Range of the IP Pool

1

IP Pool done, we can proceed to creating the PPPoE server.  Once you have a new PPPoE server creation window open, simply choose the interface of the MikroTick router that you would like to cat as the PPPoE server, in this example I ave chosen the wlan1 card.2

Create a profile for the PPPoE server to use.  This profile is where we will do some basic bandwidth management.  This is also where we will specify the use of the IP Pool we created earlier.  You can create as many profiles according to your need, all with different bandwidth speeds, and simply apply them to the relevant users.3

4

Creating profile we can proceed to create some users.  This is done in the “Secrets” tab. Simply choose the Username and Password that you would like to dedicate to your client, select the profile that was created and you are ready to go. You may create as many users as you wish.  Your client can now dialup to this PPPoE server by creating a PPPoE dialup connections.5

How To Configure Hotspot Server in MikroTik


How To Configure Hotspot Server in MikroTik
Hotspot is a way to provide internet access to subscribers by means of an easy to use web login interface.  This gives the owner of the hotspot full control over download limitations, speed/bandwidth management,  billing without tension to configure each client machine.  Service of the hotspot can be access just entering the credentials in any type of browser without making any dialup connection.  Personally, I like hotspot very much it is very helpful in Wireless scenarios.

Log in to the freshly installed router.  Please ensure there is no previous configuration is held with your routerOS as these configuration may conflict with new one.

First of all we will configure Internet connection.  You should have internet by means of DSL Router/Modem or something like that.  If you have DHCP service enabled in your router/modem so we have to setup DHCP client option in our MikroTik routerOS.1

Next Step is to ensure that your MikroTik can hand out DNS requests to clients  which obtained from the DHCP server. So check on allow remote requests.2

Lets check and make sure your MikroTik has internet connectivity by sending a ping command to Google Server. (8.8.8.8)3

As you know I am configuring the hotspot for my Wireless users so, I need to start configuring the wireless interface to give connections to the clients.  First of all I will assign a new IP address to the interface. (If you are configuring on wired media so just follow the same instruction on your eth2 interface).  Choose whatever IP scheme as you want but must be different from internet DHCP server.4

After assigning the IP to client end interface (Wlan) we have to configure this interface to accept wireless connections.  Click on the Interface button at the top right and then proceed with double click on your wlan interface.5

When the setting window appears, click on the Wireless tab at the top and set the Mode to ‘AP_Bridge’, This will configure the wireless card as an Access Point for clients to connect to.  Set the Band to 2GHz-B/G which is most common band where wireless devices operates.  SSID is the name of your wireless network and can be set to whatever you want.  In the last click Apply button and then proceed with clicking ‘Enable’ button to turn the interface on.6

Now interfaces settings completed.  Time comes to configure Hotspot setup, lets start Click on IP then Hotspot and choose Hotspot Setup as showing in picture below.7

Choose the Interface where hotspot server will run on, mine is wireless so I am selecting the same then click next.8

Upcoming window will allow you to choose the local address range of your hotspot.  This will be based on the IP address that we have already assigned to our wireless card.  Masquerade Network option must be checked to provide the internet to the clients.9

Here in this option we will choose the IP address Pool (Range) for our hotspot network based on wireless interface IP address assigned earlier.10

Just Click next as we are not using any SSL/HTTPS Certificate Here. 11

We are not configuring the SMTP server just leave as it is click on next.12

This window will allow you to specify DNS servers that will be given to the hotspot users/clients.  This is automatically based on the information received from the internet DHCP server.

13

The DNS name is the name of your network where your client will be re-directed when they want to login.  It would be react just like website which will ask from the users for their Login ID/Password.  It must be unique from any Web/DNS address on the Internet.14

Last option will ask to set up the Username & Password for first Hotspot user for Client15

16

Mikrotik Limiting User Access with DHCP (or) 32


Mikrotik Limiting User Access with DHCP (or) 32
Operator had PPPoE Server with DHCP service. All users gets ip of 10.0.0.0/8 subnet via his mikrotik’s dhcp server , This way flooding from one pc can be broadcast to all over the pc’s on the network, so I just change the netmask to 32 , this way user will not be able to communicate with any other pc on the lan, even with the server, but You can connect the pppoe service because it works on mac address broadcast. After connecting to pppoe , user will be able to use internet without any issue.

Goto IP
DHCP SERVER
Double click on your DHCP Server
Click on “Add ARP For Leases”dhcp-server-add-arp-to-lease

Now Goto IP
DHCP SERVER
Networks
CLick on + Icon
Address, type 0.0.0.0/0
Netmask, type 32

dhcp-32-subnet

If you want to restrict users that only those users who gets ips from your DHCP  server should be able to communicate with your server

Goto Interface
Double Click on your LAN interface
ARP, Select Reply-Onlyset-interfrace-arp-to-reply

User Enters IP address on his Localhost, He will not be able to Communicate with your Server and use the Internet Service.

How to Block Search Winbox Mikrotik


How to Block Search Winbox Mikrotik 
Mikrotik Winbox can search  & find Mikrotik devices connected to a network PC Laptop us. With this feature we can know Winbox Mac Address, IP Address, Identisa Mikrotik, RouterOS version, and its type RouterBOARD.

Winbox unblock

Blocking Search Winbox Mikrotik
Download Winbox Mikrotik
Login Mikrotik via Winbox
Go to the menu Tools
MAC Server
MAC Ping Server
Uncheck the MAC Ping Server EnabledMAC ping Server

Winbox Go to Interface tab
Click on “all”
Click on the cross to disable MAC Server Winbox Interface

Enter the IP Menu
Click On Neighbors
Here the interface is connected to other devices will appearIP Neighbors

Interfaces in Discovery Tab
Select the interface which will be blocking search Winbox
Click the sign of the crossDiscovery Disabled

Now Open Winbox try again and try to do a search.
Mikrotik Winbox will not be foundWinbox Blocked

Block search via MAC Address Mikrotik login. So just be able to log in using Winbox IP Address only. If you still want to be able to login via MAC Address, steps 3 and 4 above can be bypassed.